Software-ProblemeSuchen
Home Nach oben

Stand: 16.11.2016

Überblick diese Seite


Straßenkategorisierung "Haupt" - "Mittel" - "Neben"

  • Bezug der folgenden Aussagen: FW 2.70, Routenerstellung am Gerät, nicht in Mapsource.
  • Daß Garmin hier ein Problem hat, ist in den einschlägigen Foren hinlänglich diskutiert worden:
    • Autobahnen und Bundesstraßen fallen in die selbe Kategorie "Haupt"
    • die Priorisierung mit den Schiebereglern führt zu bisweilen sehr erstaunlichen Ergebnissen.
  • Fazit:
    • der geringstmögliche Unsinn passiert mit der Einstellung "Beste Route" - in den Foren wird bisweilen empfohlen, das Autobahn/Bundesstraßen-Problem mit ""Kurze Rechenzeit" wenn schon nicht zu lösen, so doch brauchbare Ergebnisse zu erzielen. Kann ich so nicht unterschreiben.
    • Alternativen: "Kürzeste Entfernung", oder Planung mit Mapsource und Übertragen als "Autoroute"

Beispiel-Route

  • Startpunkt: 91080 Spardorf
  • Ziel: 91719 Hechlingen am See
  • das ist ein kleiner Trip von ca. 90 km durchs Fränkische

Option "Kürzeste Entfernung"

 

87,6 km

Option "Eigene Präferenzen"

Berechnungsmethode: "bessere Route": bewirkt äußerst merkwürdige Ergebnisse

  • im folgenden wurde hauptsächlich die "mittlere" Kategorie verändert - 454 km !!!
    die Einstellung sieht doch an sich vernünftig aus, oder? 454 km - Routing erfolgt über Stuttgart !!!
    "Erhöhen" der Kategorie "mittel" ... dasselbe wir vorher
    Aber jetzt: "mittlere" auf 100% ... erst jetzt erscheint wieder ein halbwegs vernünftiges Ergebnis, ...
     
      ... wenn man jedoch genau hinschaut,
    erscheint dieser Umweg doch fragwürdig
    sobald man auch nur einen Klick nach links geht ... ergibt sich diesmal sogar eine Länge von 526 km !!!

Berechnungsmethode: "beste Route" - liefert bedeutend vernünftigere Ergebnisse

im folgenden wurde wieder hauptsächlich die "mittlere" Kategorie verändert

  vernünftig
auch das vollkommene Ausschließen von "Haupt" ändert nichts! gleiche Routenlänge wie eben
Zurückdrängen der "mittleren" Kategorie ... ... verlängert die Route - das ist logisch.
aber jetzt: "mittlere" auf 0 setzen bewirkt ... ... routet jetzt über die Autobahn ...???

 


Updates

Firmware

  • Bisher immer störungsfrei verlaufen. Stand jetzt [Jan. 2010]: 3.40.

Karten aktualisieren (City Navigator)

  • siehe auch "Andere Karten installieren"
  • Bis Nov 2009 immer vollkommen reibungslos.
  • Betr. "welcher USB-Port" und "alle anderen Geräte aus": hier hatte ich nie Probleme.
    • es wird davon abgeraten, einen USB-Port ("Multiplikator") zu verwenden.

Generelle Auffälligkeiten

November 2009: Wechsel auf "Lifetime-Update" - verbunden mit Installationsproblem

  • Dabei folgendes Problem (teilweise Zitate eines anderen Anwenders aus dem Forum):
  • 3GB-exe ("Garmin_rmu_cneunt2010.exe" und im Januar 2010 "garmin_rmu_cneunt2010_30b.exe") gestartet
  • Jan. 2010: zuerst Abbruch, weil Firmware 3.40 verlangt wurde. Selbige installiert.
  • 2. Versuch, Neustart der 3GB-EXE. Diesmal genauer hingeschaut:
    • (Jan 2010:) sehr schnell nach der Kontaktaufnahme mit dem GPS-Gerät kommt am PC die Meldung "Übertragung abgeschlossen" - das muß aber was anderes sein, denn...
    • ... die Übertragung ist offenkundig abgebrochen, obwohl das Gerät immer noch "Datenübertragung" meldet. Diesen Zustand kann man aber tagelang so belassen, es tut sich nichts mehr. Mit erhöhtem Puls das Gerät ausgeschaltet und getrennt.
  • Zustand jetzt:
    • Mapsource auf PC ist bereits upgedatet (und wieder wurde die Vorversion stehengelassen...!), dort ist offenbar alles OK.
    • auf dem Gerät fehlt der Kartensatz "City Navigator" komplett, wurde also gelöscht ...
  • 3. Versuch: Neustart der 3GB-EXE.
    • Nach einer gewissen Laufzeit kam erst diesmal die Meldung "... Kartendatei für das GPS-Gerät wird erstellt ..." - dies kam zuvor nicht. Scheinbar wird beim 1. Mal immer nur das Gerät gelöscht.
    • danach kommt am PC der "Fortschrittsbalken": "Karten werden auf dem GPS-Gerät installiert" ... klingt schon mal besser ...
       

Januar 2010: Version 2010.3

  • Installationsproblem s.o.
  • mit dieser Version ist auch für den 278er die Zeit vorbei, wo der gesamte Mapsource-Datensatz auf das Gerät paßt. Man muß "Regionen" auswählen. Diese wird dann in die 2 GB-Hauptspeicher übertragen. Was dann noch fehlt, kann bzw. muß auf die Speicherkarte nachgeladen werden.
    • ich habe "Mittel- und Westeuropa" gewählt, das reicht von Spanien bis Finnland ( - man fragt sich, ob die Garmin-Leute in Erdkunde geschlafen haben), Italien, Griechenland ist auch drin.
    • es fehlt aber z.B. schon Tschechien im Osten.
    • man kann dann noch eine gewisse Menge an nicht zu diesem Kartensatz gehörigen Kacheln auf eine Speicherkarte übertragen. Bei mir war das z.B. Tschechien.

Dezember 2010: Version 2011.32

Januar 2013: Problem unter Windows 8: "Karte gesperrt"

  • ich hatte auf insgesamt 4 Rechnern schon die "City Navigator NT" (aktuell 2013.3) installiert, ohne daß es weder in Basecamp noch Mapsource irgendwelche Nickligkeiten gab, ferner auch jedesmal das Typfile geändert.
  • Jedoch auf einem Windows 8 Rechner (frisch installiert) wurde in beiden Programmen CN als "gesperrt" gemeldet.
    • Die angebotene Freischaltung über Netz funktionierte jedoch nicht, obwohl ich nacheinander alle Codes (8-stellig) oder auch Freischaltcodes (25-stellig) meiner ca. 10 Versionen, die alle über die Garmin-Seite angezeigt wurden, eingegeben habe - natürlich bei angeschlossenem Gerät und korrekter Serien-Nummer.
    • hier kommt man an alle Codes (8-stellig) und Freischaltcodes (25-stellig):
    • mehrfaches Deinstallieren und Neuinstallieren von Karten und Software, mit variierender Reihenfolge brachte keinen Erfolg
  • Hinweise aus dem Netz:
    • "Wenn die Karte das erste mal freigeschaltet wird, bitte den Knopf "Karte freischalten" verwenden, wenn die Karte bereits mal freigeschaltet war, den Knopf "Freischaltcodes abrufen". Hierbei werden der oder die 25-stelligen Freischaltcodes in MapSource bzw. Basecamp eingefügt. Gleichzeitig wird eine gma-Datei in das Verzeichnis "%appdata%\garmin\maps" gespeichert (Windows XP). Nach einem Neustart von MapSource bzw. Basecamp sollte es dann funktionieren."
      ð
      eine solche *.gma-Datei konnte ich am angegebenen Ort nicht finden! Das war schon mal ein Hinweis.
    • ein anderer User berichtete, daß nach einem Versuch mit Firefox statt IE die Sache geklappt hat.
    • "Den Freischaltcode musst Du in Basecamp eingeben: Extras-> Kartenprodukte verwalten -> Freischaltregionen -> Hinzufügen. Da den Code eingeben. ich hatte das selbe Problem."
      ð
      das habe ich getan: also den 25-stelligen Code, der sich auf die aktuellste Version bezog, eingegeben und gespeichert. Effekt war aber nur der Wechsel von „Karte gesperrt“ auf „Karte nicht authentifiziert“ …
  • Lösung: vor allem aufgrund des ersten Hinweises bin ich aber drauf gekommen, mal nach *.gma zu suchen auf der gesamten Festplatte. Und siehe da: es fanden sich gleich mehrere (warum auch immer?).
    • Durch „freischalten“ oder „abrufen“ wurden offenbar Dateien abgelegt unter:
      "C:\Users\<username>\AppData\Local\Microsoft\Windows\Temporary Internet Files\Virtualized\C\Users\<username>\AppData\Roaming\Garmin\Maps". (Auf den Pfad muß man erstmal drauf kommen.)
    • Aber dann wurden sie offenbar nicht kopiert nach: C:\ProgramData\Garmin\Maps - und dort müssen sie wohl liegen.
    • ich habe mir die vom Datum her neueste (lagen alle innerhalb 2 Tagen, solange habe ich rumprobiert) genommen.
    • Von Hand kopiert – fertig! Keine Fehlermeldung mehr!
    • Interessanterweise liegen an einem anderen (XP, nicht W8)-Rechner die Dateien nicht auf C:\ProgramData\Garmin\Maps, sondern in "C:\Dokumente und Einstellungen\<username>\Anwendungsdaten\GARMIN\Maps".
  • Mögliche Ursache: vermutlich kann der Microsoft-hauseigene Browser nicht mit genügend Rechten auf das ebenso hauseigene Verzeichnis "%appdata%\garmin\maps" zugreifen...

Januar 2014: erneut "Karte gesperrt" nach Update auf CN 2014.30

  • diesmal hat die og. Lösung vom Januar 2013 nicht geholfen
  • Protokoll siehe hier, ich habe die Datei vom Dez. 2010 weitergeführt
  • Fazit:
    • zumindestens für das GPSMap278 sollte konsequent über GarminMapUpdater verfahren werden, nicht über Communicator Plug-In und Garmin Express.
    • falls "gleichzeitig" ein Update von Basecamp ansteht, diesen unbedingt auf Funktionsfähigkeit überprüfen
    • (ob nun zuerst die Karten oder erst Basecamp aktualisiert werden soll oder muß, kann ich nicht sagen)
    • keinesfalls die vorherige Kartenversion deinstallieren, bevor nicht alles 100% getestet ist...
    • der Garmin-Support konnte das Problem schlußendlich lösen.

September 2015: erneut "Karte gesperrt" nach Update auf CN 2016.1

  • mal wieder ... nachdem es seit Januar 2014 immer glatt gelaufen ist, auf Rechnern Win7 und 8
  • natürlich über GarminMapUpdater durchgeführt, nicht über Communicator Plug-In und Garmin Express
  • die Karte wurde übrigens gleich auf das Gerät installiert, das folgende Problem ergab sich nur in BaseCamp und MapSource.
  • das Problem erwies sich als zweistufig.

Karten gesperrt

  • dies wurde wiederum durch eine *.GMA-Datei behoben, die ich vom Support (recht flott) bekam. Ich erhielt jedoch von offenbar 2 verschiedenen Mitarbeitern leicht unterschiedliche Anleitungen dazu.
  • Variante 1:
    • die *.GMA-Datei an einen beliebigen Ort speichern
    • BaseCamp (Windows):
      • klicken Sie auf "Karten -> Kartenprodukte verwalten -> Reiter 'Regionen freischalten' -> Button 'Importieren' ".
      • begeben Sie sich im "Öffnen"-Dialogfenster in den Ordner, in dem Sie die GMA-Datei gesichert haben und wählen Sie in der Dropdown-Liste rechts neben dem Eingabefeld "Dateiname" die Option "Codedateien zum Freischalten (*.gma)".
      • Wählen Sie die GMA-Datei nun aus, indem Sie mit der linken Maustaste einmal auf diese klicken und bestätigen Sie anschließend durch einen Klick auf den Button "Öffnen".
    • MapSource (Windows):
      • Klicken Sie auf "Dienstprogramme -> Karten freischalten -> Reiter 'Freischaltregionen' -> Button 'Importieren' ".
      • Rest wie bei BaseCamp.
  • Variante 2:
    • Bitte speichern Sie die *.GMA-Datei an folgenden Orten ab:
      • PC (XP): C:\Documents and Settings\(username)\Application Data\GARMIN\Maps
      • PC (Vista Win7/8/10): C:\users\(username)\AppData\Roaming\Garmin\Maps
      • Mac: /(username)/Library/Application Support/Garmin/Maps/
    • dann die Software starten, die *.GMA-Datei wurde automatisch gefunden und eingelesen, die Karte war entsperrt

Karte wird am PC nicht angezeigt

  • hiernach zeigte sich ein weiteres Problem: die Karte wurde am PC in beiden Programmen nicht angezeigt.
  • 2015.4: (Hinweis: TYP-File modifiziert):
  • 2016.1: nur die absolute "Basemap" wird angezeigt:
  • hier war dann auch der Support erstmal ratlos.
  • ich habe durch eigene Forschung entdeckt, daß in den Verzeichnissen unterhalb des gewählten Ziel-Verzeichnisses für die Karte(bei mir: "D:\Programme\Garmin\"), also z.B "D:\Programme\Garmin\City Navigator Europe NT 2016.10.gmap\Product1\00529433" keine Dateien namens *.GMP waren.
  • Offenbar war bei der Installation etwas schiefgegangen:
    • es gab zwar keine Fehlermeldung
    • es wurde auch die gesamte Verzeichnisstruktur angelegt - nur eben keine Dateien
    • die Karte 2016.10 wurde in den Programmen BC und MS angeboten
    • und auch auf dem Gerät war sie installiert worden.
    • Allerdings wurde die 2016.10 nicht in der Systemsteuerung unter "Installierte Programme" angezeigt. Es kam aber wie gesagt bei der Installation keine Fehlermeldung.
  • Ich habe nun einfach nochmal die Installation wiederholt, diesmal mit der Option "Nur auf Computer", und jetzt ist alles ok. (Erstaunlicherweise gibt es jetzt auch nicht etwa die Karte "2016.10" zweimal zur Auswahl in den Programmen, ich hatte mich schon auf einen Gang in die Registry eingestellt...)

 

Tip für manuelle Notinstallation

(aus: http://www.naviuser.at/forum/showthread.php?t=2944)

Vorbereitung: Aktuellen Webupdater runterladen und installieren
V2008nt in Mapsource installieren und Freischalten

Man nehme eine SD Karte im Kartenleser oder einen USB Stick mit mindestens 2GB Kapazität, öffne Mapsource, wähle die installierte V2008NT. Dann alle Kacheln der CN2008nt selektieren, einen Kartennamen angeben (wichtig: City Navigator Europe NT 2008 ALL) und einen kompletten Kartensatz auf den Wechseldatenträger generieren. Das kann je nach Rechenleistung des Rechners etwas dauern.
Wie das geht, sieht man hier.

Dann geht es wie folgt weiter:

  1. Einen Ordner c:\278 auf der Festplatte erstellen
  2. kopiere von dem Wechseldatenträger die eben erstellte gmapsupp.img nach c:\278
  3. Benenne das File in von gmapsupp.img nach gmapprom.img um
  4. Wechseldatenträger entfernen und das GPS Gerät per USB anschließen
  5. Eingabeaufforderung öffnen (Start, ausführen, cmd.exe)
  6. Folgenden Befehl eingeben (vorausgesetzt der Webupdater ist in diesem Verzeichnis installiert:
C:\Garmin\WebUpdater\WebUpdater.exe /upload_file rgn=49 path=C:\278\gmapprom.img -autorun usb /unlock_check fid=284 pid=1 /i

Achtung: wer diese Anleitung für andere Karten als die hier im Beispiel verwendete CN2008nt einsetzt, muss die FID anpassen! Die gültigen IDs findet man hier: http://www.naviuser.at/forum/showpos...89&postcount=1

Abschicken, warten und hoffen.

Das klingt weiterhin nach einer Möglichkeit den Internen Speicher für eigene Karten zu nutzen.